Repository Source code not complete atm?

Developer
Jul 29, 2012 at 3:04 PM

Decided to get an updated copy of Rawr to see the current status and get an idea of how things are shaping for MoP. (Also realised I had previously made a change in terms of reforging graphs, which I had never committed. Managed to commit it now for Rawr4. If useful, we can add it to Rawr5 as well.).

I tried a complete checkout and had some issues:

Rawr4.3 didn't compile since it seemed to miss Rawr.Moonkin\ProcEffect.cs. I still had an old working copy and managed to locate the file there.

Rawr5 doesn't compile. It complains about Rawr.Base\Networking\ElitistArmoryService.cs and again the Moonkin ProcEffects files. Again tried to copy the old source file, but it seems there where a bunch of changes and ElitistArmoryService is trying to modify values that are now read-only.

Is it just my checkout or are we missing some files in the repository?

 

Coordinator
Jul 30, 2012 at 1:36 AM

The SL version was badly out of date, I'll check in a synced up version.

Coordinator
Jul 30, 2012 at 12:42 PM

Rawr4 shouldn't have needed ProcEffect.cs.  I'll take a look at it to figure out why.