This project is read-only.

How the hell do I compile?

Topics: Retired
Dec 19, 2008 at 1:22 AM
I am a bit new to this compiling stuff, but I figured out enough how to (somewhat) get Rawr compiled.

What I try to do is download the latest source code (or the second latest) and write "csc program.cs" but I get errors no matter what source code I try.
What do I write to successfully compile Rawr?
Dec 19, 2008 at 1:55 AM
If you have c# installed (recommended) just open the Rawr.sln and compile from there.

If you only have the .NET framework try with this from command line "msbuild Rawr.sln", you'll need to have environment settings correct for it to recognize msbuild or manually go to where it is installed (typically something like C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727)
Dec 19, 2008 at 2:13 AM
I downloaded the .NET framework and tried with that, but that didn't work.

I'm installing Visual c# 2008 Express right now.
Dec 19, 2008 at 2:25 AM
Edited Dec 19, 2008 at 2:27 AM
I somehow got it to work with C# Express, but it alerts me of that I need some 3.5 components. Do I need the 3.5 SDK too?


It works - but it's a bit slow. It was just a warning, not an error :p


Only the items I load from CharacterProfiler seems to load - not any other item.
Dec 19, 2008 at 3:04 AM
How to make it faster: In the toolbar in dropdown change from Debug to Release. To start it use Debug->Start without debugging or launch Rawr.exe directly.

To have all items copy the xml files from the Data folder in the downloadable version to where the files are compiled from source (should be Rawr\Bin\Release\Data).
Dec 19, 2008 at 3:14 AM
Edited Dec 19, 2008 at 3:19 AM
That seemed to work... sorta. When I put it to release, it tells me that it could not find Rawr.exe. 
Or quote:

"Visual Studio cannot start debugging because the debug target 'C:\Documents and Settings\Adminstrator\Desktop\RAwr\bin\Release\Rawr.exe' is missing. Please build the project and retry, [...]"

I tried to build the project (F6) but instead I get 2 errors:

- Error 17 Assembly 'C:\Documents and Settings\Administrator\Desktop\RAwr\bin\Release\Data\Rawr.Base.XmlSerializers.dll' must be strong signed in order to be marked as a prerequisite. Rawr
- Error 18 Assembly 'C:\Documents and Settings\Administrator\Desktop\RAwr\bin\Release\Data\Rawr.Base.dll' must be strong signed in order to be marked as a prerequisite. Rawr

Does that mean I have to put those 2 .dll's into bin\Release too then?


Never mind... I put the rawr.exe from the 2.1.4 release into bin\Release and it seemed to work. The bug I thought they had fixed does not seem to be fixed though (regarding haste for tree druids. Haste is a nearly useless stat for us)

Now... just to learn C# so I can help to this wonderful project :D

I appreciate your help Kavan.