Rawr + Mac

Topics: Retired
Feb 3, 2009 at 2:12 PM
First of all, thanks for such an amazing program I use it quite often at home on my windows system.

My question however is about my work computer, I'd love to able to get it to work here. I have followed a lot of the discussions here and was able to get as far as launching in Terminal, but getting the following error (to be clear it never actually launches, just sits for a second or two then displays this)

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.WindowsFormsSynchronizationContext ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.ThemeEngine ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.ThemeWin32Classic ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.KnownColors ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.GDIPlus ---> System.DllNotFoundException: /Library/Frameworks/Mono.framework/Versions/2.2/lib/libgdiplus.dylib
  at (wrapper managed-to-native) System.Drawing.GDIPlus:GdiplusStartup (ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)
  at System.Drawing.GDIPlus..cctor () [0x00000] 
  --- End of inner exception stack trace ---
  at System.Drawing.KnownColors..cctor () [0x00000] 
  at System.Drawing.KnownColors..cctor () [0x00000] 
  --- End of inner exception stack trace ---
  at System.Drawing.Color.get_Black () [0x00000] 
  at System.Drawing.Color.get_Black () [0x00000] 
  at System.Windows.Forms.ThemeWin32Classic..cctor () [0x00000] 
  --- End of inner exception stack trace ---
  at System.Windows.Forms.ThemeVisualStyles..ctor () [0x00000] 
  at System.Windows.Forms.ThemeVisualStyles..ctor () [0x00000] 
  at System.Windows.Forms.ThemeEngine..cctor () [0x00000] 
  --- End of inner exception stack trace ---
  at System.Windows.Forms.SystemInformation.get_MenuAccessKeysUnderlined () [0x00000] 
  at System.Windows.Forms.SystemInformation.get_MenuAccessKeysUnderlined () [0x00000] 
  at System.Windows.Forms.Control..ctor () [0x00000] 
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.Control:.ctor ()
  at System.Windows.Forms.WindowsFormsSynchronizationContext..cctor () [0x00000] 
  --- End of inner exception stack trace ---
  at System.Windows.Forms.Control..ctor () [0x00000] 
  at System.Windows.Forms.Control..ctor () [0x00000] 
  at System.Windows.Forms.ScrollableControl..ctor () [0x00000] 
  at System.Windows.Forms.ContainerControl..ctor () [0x00000] 
  at System.Windows.Forms.Form..ctor () [0x00000] 
  at Rawr.FormSplash..ctor () [0x00000] 
  at (wrapper remoting-invoke-with-check) Rawr.FormSplash:.ctor ()
  at Rawr.FormMain..ctor () [0x00000] 
  at (wrapper remoting-invoke-with-check) Rawr.FormMain:.ctor ()
  at Rawr.Program.Main () [0x00000] 

Im using Mac OS X version 10.4.11 on a Dual 2 GHz PowerPC G5, if that helps at all.

Thanks in advance.
Coordinator
Feb 3, 2009 at 4:53 PM
Looks like it can't find one of the mono assemblies... Which is odd, if the rest of Mono is installed. Also, several users have reported weird errors on 10.4, but as soon as they update to 10.5, it 'just works'. So my best suggestion would be to install 10.5 if possible, apply all system updates, then reinstall mono. If you can't upgrade to 10.5 yet, just try a reinstall of mono, plus restart.