This project is read-only.

Option to download from PTR wowhead

Topics: Rawr.Base.Items
Mar 20, 2009 at 6:29 AM
Since we are using 3.1 models and talent trees, how about an option to download from the PTR wowhead so we can more easily get the new loot that is being discovered.
Mar 20, 2009 at 6:36 AM
Already done, it's in the latest development build, if you build from source control. Otherwise, it'll be in the b5, this Sunday.
Mar 20, 2009 at 1:39 PM
Nice to know I pre-empted the demand :)
Mar 20, 2009 at 5:10 PM
Yep. *hands Levva the Crystal Ball Award*
Mar 20, 2009 at 5:20 PM
Edited Mar 22, 2009 at 2:13 AM
Cue acceptance speech...

Oh this means so much, sob. I'd like to thank my agent, my family, my friends, the cast, the director, the producer, the crew, in fact everyone who worked on the project, and especially..."

Mar 21, 2009 at 7:46 PM
Hey now...

;)  Looking forward to it!
Mar 23, 2009 at 5:30 PM
I cannot import PTR items when I copy & paste the link to the item. I do have the checkmark in "Load Possible Upgrades from WoWhead" option to the right.

Is there some way other than manually putting in the stats for the items into RAWR from
Mar 23, 2009 at 5:50 PM
Edited Mar 23, 2009 at 5:51 PM

Are you using the newest (as of yesterday) version of Rawr, v2.2.0b5?  All the current items in the PTR side of Wowhead are already in there.  If something is missing, try using the new "Tool > Load Possible Upgrades from Wowhead > Use PTR Data" action.

If the items are not showing up in your listings of item comparisons, go to "Tools > Edit Item Filters" to make sure that the 3.1 data is being shown.  (After looking at this myself, apparently this is not an issue, as long as you have "Unknown" items listed.)

Hope this helps!

Mar 23, 2009 at 6:29 PM

The tick box affects the behaviour of "Load Possible upgrades from Wowhead" from your comment it would appear you believe it affects editing items? Otherwise what do you mean by "I copy & paste the link to the item"?

What you do is click on "Load Possible upgrades from Wowhead" and it will load all possible upgrades for your character. If you tick the "Use PTR data" it loads them from if its unticked it loads them from Nowhere is there an option to paste a link.

Mar 23, 2009 at 8:40 PM
"Nowhere is there an option to paste a link."

That's not entirely true, if you go into the "Edit Items" dialog in rawr, and at the bottom-left click "Add..." (to add a new item), you then have the option of inputting the item ID or a wowhead link.  If you put in an ID of an item from, it doesn't work, and if you put in a link from, it doesn't work.  This is what I was trying to do before you implemented the "load upgrades from wowhead" option, and it may confuse some people.  Of course, adding that option makes this adding a new item thing rather irrelevant, I do see where the concern is.
Mar 23, 2009 at 8:42 PM
On second thought, I just entered the wowhead link for scale of fates: into this dialog and it seems to have added the item just fine.  But then, since the item was already in rawr and it just made a duplicate entry, I went to delete the duplicate....and rawr crashed.  Weird.
Mar 23, 2009 at 8:58 PM
Yeah, I was going to say that I copied and pasted a link (or just the item number) into the "Add" dialog box that comes up. It works fine and recognizes the item when it's already in the database. However, if the item is not in the database (i.e. Conquerer's tanking helm for paladins), it asks me to add the item.

I will try the option of "Load upgrades from wowhead". I wasn't aware that imported anything *new*, I thought it only updated the existing items with refreshed wowhead data.

Mar 23, 2009 at 9:00 PM
Allright, I'm an idiot, that worked!
Mar 24, 2009 at 4:31 PM
Using a URL in the item add edit box should now work in the next version.
Mar 24, 2009 at 4:43 PM
Only issue I have found, is the info is not complete for ptr items (location and such).  The item appears in the list though and the stats seem fine.

If I right click and open in wowhead, it goes to www.wowhead instead of ptr.wowhead and is not loaded.  If I try to refresh the item from wowhead it cannot find the item.

It's not important really since it's just ptr stuff and I'm not asking for it to be corrected, but maybe this is the issue the OP had.