Loading On Mac OSX

Topics: Retired
May 20, 2009 at 12:19 AM

Will Someone please help me? I have been at this for 3 hours and i have loaded mono and rawr and the new wow patch and all i have gotten is a big $%^*&ing headache. Are there uptodate instructions your hiding somewhere?

May 20, 2009 at 2:42 AM

The uptodate instructions are in the readme, with the exception of the note in the known issues, that the currently latest version of Mono (2.4) is broken, and to use Mono 2.2.

May 20, 2009 at 3:38 AM

Well theyre a little confusing to me, it says to locate the files with Terminal and ive tried dragging the files to use them but its not working. Could you maybe explain them a little better?

May 20, 2009 at 7:35 AM

You should look into basic guides to the Terminal; it's a command line interface, not a GUI.

May 20, 2009 at 2:19 PM

Yep, which doesn't mean dragging a file to it is useless.

When you drag a file (or directory) to a terminal window, what will happen is that the full path of that file (or directory) will typed out in that window. This is uber useful.

I too being a Mac user, and even though I'm a heavy Terminal user, I ended up opting for a Terminal-less solution, running Rawr not with Mono, but within a virtual machine. The reason is that at the time I tried it out, Mono was a big bag of hurt. It may have improved since.

I personally use VMWare Fusion as my Virtual Machine software, but Parallels Desktop works too I'm sure, and probably the free VirtualBox (http://www.virtualbox.org).

The drawback with the VM approach is that you need a licensed copy of Windows :-(

The last possible approach, which I haven't tried either, is to use Wine (http://www.winehq.org/) or a derivative such as the commercial CrossOver (http://www.codeweavers.com/products/cxmac/). This an attractive approach, as it doesn't require a Windows license, though I don't quite know how it can work for .NET apps such as Rawr.