v2.3.22 Equipping Gems - Assistance please!

Topics: Rawr.Base.Items
Mar 18, 2015 at 8:51 AM
Hello - I'm currently using the v2.3.22 for the 3.3.5a Wotlk Patch. Very awesome/easy to use program and congratulations to the people that constructed this. Other than the odd lag/delay on processing certain things, the program runs great! I've downloaded this and used it right away and it seems self explanatory with a few read-throughs of FAQ's and such. (The newest version seems WAY MORE confusing, turned away from it ASAP. This version seems so much more user friendly, ANYWAYS.......

I'm trying to test out different gear sets to find an actual bis for an avoidance & armor & Sindragosa tank set. Oddly enough I've encountered a bug (I think)? I can't seem to equip gems anymore. Perhaps 20 minutes into my assembly of gearsets went by smoothly, Then all of a sudden I can't seem to equip gems...


I'd like to equip a nightmare tear into my headsocket to activate the meta (Requires 2 blues & 1 red). When i right click the broken ramskull, select "Equip custom gemming", and try to change the Solid Majestic for a nightmare, it doesn't list ALL of the gems like it used to, only the solid majestic is within the list.

Some assistance? Maybe i clicked an incorrect option? Yes i've tried googling/skimming through your articles on this website.... Figured id rather get a direct answer.

Thank you for your time/reading.
Mar 20, 2015 at 4:00 AM

That item is unique equipped, do you have one selected in another piece of gear?

The reason the newer versions are confusing is because they get changed with WoW expansion releases, where they totally overhaul how characters work.
Mar 20, 2015 at 5:20 AM
No sir, i do not have another nightmare tear equipped anywhere in my gear set. I may have explained it poorly. Another screenshot has been posted showing what happens... (I had to screenshot two seperate images onto one, thats why it looks like a chopped screencap).


Only the Solid Majestic gem pops up within the list given, although I want to equip/mixmatch other gems into the socket. This happens with ALL my gear thats been setup. Perhaps this screenshot will clarify what I mean. Nothing is typed into the filter, and i haven't touched the 'sort' option.

Thanks again for the reply Jothay. Hopefully you can assist me! :)