Mono v2.4

Topics: Retired
Aug 24, 2009 at 6:21 PM

Quote from the front page: "If you're running Rawr via Mono on OSX/Linux, you'll need to use Mono v2.2. The latest version (v2.4) has a bug that prevents Rawr from running."

What is the number of that bug, please.

I run Debian Stable (Lenny). Testing (Squeeze) has v2.4.2.3 available, which I can use. There is a long list of bug fixes for v2.4.2.3 and I'd like to see if the bug that is mentioned in the quote is in that list.

 

Thanks,

slopoke

Coordinator
Aug 24, 2009 at 9:01 PM

I do not know. Feel free to try it and let us know if the newer version has fixed it.

Aug 27, 2009 at 5:42 PM

I found the bug that is causing Mono 2.4 to not work, https://bugzilla.novell.com/show_bug.cgi?id=434583. There is a pretty easy fix, just to not use SetResolution on line 383-384 in ItemIcons.cs while on Mono. I commented it out and rebuilt it with MonoDevelop, and then Rawr would run just fine with Mono 2.4.