This project is read-only.

Exporting Rawr data to LootPlan.... doesn't seem to do anything?

Topics: Retired
Sep 2, 2009 at 2:49 AM

Literally. I can't find a new file created anywhere by this and can't get LootPlan to import. Bugged?

Sep 2, 2009 at 7:13 AM

It doesn't create a file, it copies it to clipboard so you can paste it in game.

Sep 2, 2009 at 7:10 PM
Edited Sep 2, 2009 at 7:12 PM

This function is not well documented, the buttons do not name common Windows commands, and the "export to Lootplan" is misleading, so I appreciate Rhinobite's frustration.

In Rawr, the "Export to Lootplan" should probably say something like "Copy to clipboard (Lootplan format)"

After several attemtps, I got it to work:

  1. Open WoW for your character, and then the lootplan gui.  Go to the import tab.
  2. From rawr, open (or create) your upgrade table
  3. Choose the "Export to Lootplan"... this is really just copying the table in LP format to your clipboard
  4. Return to WoW, click somewhere in the import text box, and click "Import" or just ctrl-V; both do a "clipboard paste"
  5. Go get coffee... the paste can take a minute or so (during which time WoW appears to be frozen for me)
  6. After the paste is complete, you will see your gear in the text box in the LP format.
  7. Click "Accept" to load into the lootplan database (this happens more quickly)
  8. Unless you've turn off some chat items, you will get a list of confirmation messages in the general chat box as the items are loaded.
  9. Rinse and repeat for each toon (don't forget to logout to your next toon!)

Hope that this helps,



Sep 2, 2009 at 11:20 PM

Well it did help, I can get everything copied into the LP gui, unfortunately once I hit 'Accept' nothing happens. I gave it some time because it was such a large list, with no result, and then took out everything but a single item. With the single item, I can hit 'Accept' and again nothing will happen, unless I then hit 'Import' at which point I get an error saying the item does not exist (ex: Error: '47192: Upgrade Score 142993.2;' does not exist). This looks as if the format is incorrect, LP is looking at the entire statement as being the item ID instead of just the first digits. I tried messing around with the format but I can't get LP to recognize anything. This isn't Rawr related but I was hoping someone might have an idea of what I'm doing wrong.

Sep 19, 2009 at 7:57 AM

It's odd, but this worked for me:  Since the update, IMPORT does not do the "Paste".  So, I clicked "Save to Lootplan" (which actually copies to clipboard in LP format), then I opened NotePad and pasted the entire list.  I then coped it AGAIN (ctrl-A, ctrl-C) and went to the LP/GUI in WoW.  I pasted (ctrl-v) in the text box and hit ACCEPT.  It appeared nothing happend, and for some reason, the IMPORT button only scrolled the textbox.  So, I deleted everything in the text box (click in the box, ctrl-a, DEL) and THEN clicked IMPORT... and it worked.

I have no idea what he did in the code; I didn't look.



Sep 19, 2009 at 5:34 PM

What I usually do is as follows, it works for me:

  1. Click "save to looplan"
  2. Do "/lootplan gui" in wow and then go to the import box
  3. Paste the text into the box
  4. Click Accept
  5. Click Import a bunch of times until it scrolls all the way to the bottom
  6. All your items should have been imported (at least the ones you have in your item cache)