This project is read-only.

Exclude specific gems

Topics: Rawr.Base
Sep 23, 2010 at 6:37 PM

I have been trying to use the optimiser to help me change my talents/gems slightly but it keeps telling me that armor penetration is the way for me to go.  With the changes coming in Cataclysm and the removal of armor pen I would like to avoid respeccing for ArP but can't seem to find a way of disabling the ArP gemming options. Is this possible at the moment?


Sep 23, 2010 at 6:39 PM

Go to Tools > Edit Gemming Templates and turn off the ArP ones

Sep 23, 2010 at 7:34 PM

I thought I had done that already - I went through and unchecked any of the combinations with ArP gems in, I even tried setting an additional requirement on the optimizer of less than 40% arp (around what I am at the minute) but it didn't seem to like that either.


Sep 23, 2010 at 8:28 PM

Does the gear you have equipped have ArP on it?  That will flag it as available in the actual Gem list.  You have two options:

a) Uncheck the equiped gear and Ctrl-Check the gear that has the gemming options you want.

b) Go to Slot:Gems -> Normal and find the ArP gems.  Uncheck them and run the optimizer.  You'll get an error saying that the equipped ArP gems are marked unavailable.  Click Ok anyways and let it do it's thing.

Sep 24, 2010 at 7:39 AM

I'm not using any ArP gems at the minute. My kit has some on but thats all. Looking on the gems menu the ArP gems have no diamond next to them for me to remove but is is coloured a pale red colour which I can't seem to change at all.


Sep 24, 2010 at 8:25 AM

If the optimizer is using ArPen gems, one or both of the following are true:

  1. You have a gemming template enable which contains an ArPen gem.
  2. You have an ArPen gem marked available in the Gems chart.
Oct 2, 2010 at 1:19 PM

I have a similar situation with spellpower gems on my shaman so I hope you don't mind me joining this topic as it seems related. I currently have gemmed for spell power but I want to see how gemming for haste will affect things. I have done everything I think I should yet it is still telling me to go with runed cardinal ruby so:

  1. I have disabled all gemming templates that include runed Cardinal Rubies including, for the sake of simplicity, all jeweler specific templates. The only 2 templates I have available are Straight 20 haste (5 x Quick King's Amber + Meta) and Haste mixed (Haste/SP, Haste, Hast/MP5, Haste, Meta).
  2. On top of selecting only these 2 templates, under the optimizer settings in Tools > Options... I have disabled "Consider gems in enabled gemming templates to be available".
  3. In Slot: Gems > All Normal I have unselected all gems except Haste/SP, Haste and Haste/MP5

So I run optimizer and whether I check "Override regem" or not it first gives me a warning saying so many gems are not available including Runed Cardinal Ruby and yet when I run the optimizer it still tells me to equip items with Runed Cardinal Ruby (some items are being changed to no longer use that gem and instead go with the Haste/SP or Haste/MP5 but some items are sticking with the full Spell Power ones.

Am I missing something?

Oct 2, 2010 at 1:32 PM

Really, we'd have to see the character XML to really figure out why.  I'd suggest making a ticket if you truly believe it is marking gems when you don't have them marked, but chances are we'll find somewhere in your XML that it is.  

Or, for the Adventurous, try this.  Right click on your character XML and click 'edit' or open it from Notepad.  Search (hit ctrl+f) for the item ID of the offending gem, in this case 40113 (Runed Cardinal Ruby).  You can also, for the more adventurous, use replace instead (ctrl+h) and change 40113 to 40155 (Reckless Ametrine), then save the file.  This will replace any Runed's you actually have in any gear you ever clicked as available into reckless.

If you do the adventurous route, and it STILL uses the wrong gems that you are SURE you don't have selected, then please post an issue in the issue tracker, as it could be a bug.