This project is read-only.

Optimizer doing weird stuff

Topics: Rawr.Addon, Rawr.Base.Optimizer, Rawr.Mage
Mar 14, 2011 at 12:11 PM

Hello everyone,

I've been using Rawr since late Wrath, but only starting the optimizer since Cata came out. I'm playing a fire mage and i really like that there are tools such as Rawr to help us mages out.

However, when i'm running the optimizer, it comes up with some really stranges results from time to time.

For example, i run a thorough optimizer (as i always do) and three to four items that i have equiped simply dont show up in the result window. I've manually deselected and reselected the green diamond next to each piece of gear that i have, so that Rawr actually can see that those items are 'available' for optimizing. I thought it was some kind of bug, so i just restarted the program and reran it. The second time i got some pieces that werent on the original scan on the result window, however other items suddenly disappeared. It's quite annoying that i just dont seem to be getting a complete result screen with ALL of my gear in it.

I'm using the latest Rawr online version.

Please help me out here, i'm sure i'm doing something wrong, but i just cant figure out what it is.



Mar 14, 2011 at 4:37 PM

The results screen is designed to only show the items that change. If the gear appears to be "missing" it's because you aren't supposed to change that gear.

Mar 14, 2011 at 6:44 PM

But how do you explain the fact that sometimes a dagger appears in the result window, and the second optimize i run without doing anything else or changing anything, the dagger has disappeared from the list?

Mar 14, 2011 at 6:46 PM

In the second optimize, the dagger didn't change, something else did. Optimizer results don't always come out exactly the same, even on the same settings. That's the nature of the algorithms we use to make the optimizer work.

May 6, 2011 at 9:14 AM

Hello - hope this is the correct spot to place this question about Optimizer and my Mage.

I have just installed the latest version of RAWR - 4.1.04, and went to optimize my gear. I keep getting the message that my Cloak and Leggings are not enchanted - though they are. Cloak has Lightweave Embroidery (Rank 2), and Leggings have Master's Spellthread (Rank 2). I select to continue through this advice and then get the message that neither of the two enchants are available.

I did have this problem a while back with previous versions but it seemed to resolve itself, though I do not know how?? I clearly need to have these enchants recognized to be able to use the optimizer option to give advice on reforging.

Can you advise me how to resolve this problem please.

May 6, 2011 at 3:58 PM