Mac OS X problems

Topics: Retired
Aug 7, 2008 at 1:29 PM
Hi.
I installed Mono and when trying to get Rawr to work it quits suddenly and I get the following error message:

Unhandled Exception: System.FormatException: Unknown char: .
  at System.Double.Parse (System.String s, NumberStyles style, IFormatProvider provider) [0x00000] 
  at System.Double.Parse (System.String s) [0x00000] 
  at System.Convert.ToDouble (System.String value) [0x00000] 
  at System.Windows.Forms.XplatUICarbon.GetMessage (System.Object queue_id, System.Windows.Forms.MSG& msg, IntPtr hWnd, Int32 wFilterMin, Int32 wFilterMax) [0x00000] 
  at System.Windows.Forms.XplatUI.GetMessage (System.Object queue_id, System.Windows.Forms.MSG& msg, IntPtr hWnd, Int32 wFilterMin, Int32 wFilterMax) [0x00000] 
  at System.Windows.Forms.Application.RunLoop (Boolean Modal, System.Windows.Forms.ApplicationContext context) [0x00000] 
  at System.Windows.Forms.Application.Run (System.Windows.Forms.ApplicationContext context) [0x00000] 
  at System.Windows.Forms.Application.Run (System.Windows.Forms.Form mainForm) [0x00000] 
  at Rawr.Program.Main () [0x00000] 

Also when looking at the readme for mono there is one point that is worrying:

4.  System.Windows.Forms is known to not work under X11 on 10.5.  Apple has introduced a broken implementation of some extensions that we cannot disable.


I'm running 10.5 so can this be the reason Rawr doesn't work or should I do something differently?

/arvid
Coordinator
Aug 7, 2008 at 4:23 PM
Actually, that may be a little backwards, in fact... On some machines, Mono refuses to run at all unless X11 is installed. Try installing X11 and see if that fixes it? Either way, Mono's really buggy, so if you can use either Boot Camp or one of the emulators, that'd give you a better experience. Right now, we're hoping for a big new release of Mono sometime soon to fix alot of its bugs. Sorry Rawr has to rely on Mono :(