This project is read-only.

A long, long story

Topics: Rawr.Base.Optimizer
Apr 6, 2009 at 2:24 PM
Edited Apr 6, 2009 at 2:27 PM
Hi all,

A friend of mine recommended this utility to improve my gear on WoW, so I decided to download and make a try with it. I took a look to requeriments to work and I acomplished at full, a recently installed Vista x64 Ultimate with all Windows Update packages applied, including of course .NET Framework 3.5 SP1.

Well, I loaded the program and my profile from WoW Armory without problems, and then go to Optimize options, and started my problems. When I push Build Upgrade List, the error message appears:


(well, now you're thinking about so many times the people annoyed you with this problem... let me continue, please)

So, as I saw on Readme.txt and so many discussions here, I proceed to uninstall/reinstall .NET Framework (a long time, but with the hope that all will work). No way man, another time the window reporting the error message submited before. I downloaded package from this location:

Mmmm, let me try to install Rawr in another machine, an old laptop I have to make tests with O.S. and so... Download Rawr, install .NET Framework 3.5 SP1, run Rawr, run Optimize... and another time the same error. The same error on two machines... why me?

Ok, take a long breath. Tomorrow I will test again.

This morning I started from zero. I formatted the laptop and install Windows XP SP2 Spanish, no updates, only .NET Framework 3.5 SP1 and Rawr.

And here is again my problem.

Ok, one more time. Windows XP SP2 English (to avoid possible language issues, perhaps this is the problem), no updates, only .NET Framework 3.5 SP1 and Rawr. Ouch...

Taking a look to Microsoft webpage, they said that is recommended to install some updates after installing .NET Framework 3.5 SP1, so I tried too...

No no and no...

Ok, if I try to install .NET Framework 2.0? Ok, try it man. Format, download, install...


And if I install .NET Framework 2.0 and .NET Framework 2.0 SP1?

Here I am now. The progam never worked fine for me, and as you can see, I made all possible combinations. So, any possible solution will be received, because I'm sure that you inverted too many hours to made it work, and I want to enjoy with his use, but it won't work...
Apr 6, 2009 at 3:24 PM
What version of Rawr did you install?  That message used to appear for me in the older versions, but went away recently.  You can also try one of the betas -- that are getting pretty stable now.

In any case, I would go back and reinstall .net 3.5 -- that *is* the correct version to use.  :(
Apr 6, 2009 at 4:16 PM
This bug should be fixed in v2.2.0b6 the issue was that you were clicking optimise without having selected the gear you had available to optimise. Prior to beta 6 Rawr wasn't checking if the lists were empty and so crashed.

.Net 3.5 SP1 is the correct version to use, backrevving to old versions is a REALLY REALLY bad idea and will screw up your machine something rotten. Microsoft products work in an "always forward" model, you risk ruin by installing an older Microsoft product on top of a newer one. This is also why its NEVER a good idea to "just reinstall windows" (fresh install on clean empty disk works but a reinstall is always doomed to failure).
Apr 6, 2009 at 5:29 PM
I'm trying with 2.1.9 version, the actual working version on the page. I tried too with beta version 2.2.0b6, and seems to do anything when I push Optimize, the progress bar runs and these things, but arrives one point that explodes another time with same error.

So, then, what's the correct way to operate with the program? I don't understand your phrase "you were clicking optimise without having selected the gear you had available to optimise", sorry.

I have no idea what's happening
Apr 7, 2009 at 5:22 AM
Well, you'll have to tell us what the error actually is that you're having, not just that there was an error. Regardless, none of this has anything to do with different versions of .NET. Just install the latest version and leave it at that. We can't tell you what the 'correct way to operate the program' is, because we don't know what you're trying to do. You should view the Tour of Rawr video if you haven't, and I suggest you use the latest beta version.
Apr 7, 2009 at 1:29 PM
Edited Apr 7, 2009 at 1:33 PM
As I said, I get the error message when I loaded my info from Armory and try to Build Upgrade List through Optimize option. As I said, I installed the last .NET Framework version, 3.5 SP1 one. As I said, I tried the 2.2.0b6 version. I made all tests on a formatted laptop with Windows + .NetFramework + Rawr, no updates, no upgrades, no patches. Didn't read my whole message?

I'll take a look to the video, but I'm sure that I'm doing the things correctly... Thanks anyway for your answer, Astrylian.
Apr 7, 2009 at 1:45 PM
Yes but when the program "explodes" it gives you a detailed error message. We NEED that detailed error message if we are to find the issue. In your first message you were trying to be helpful and posted exactly what you did this is welcome. A couple of mistakes though. You didn't mention the version. You posted a screenshot of the error but without the vital details button clicked, the title of the error tells us very little the devil as they say is in the detail.

We do appreciate your frustration and do want to assist however we can only do this if we know exactly what the error is, what you are trying to do, and how we can replicate the error. So a little bit more info and I'm sure we can solve it together.
Apr 7, 2009 at 1:46 PM
Edited Apr 7, 2009 at 1:49 PM

What Astrylian is saying is that it doesn't help that an error occurred, in general.  When it pops up and says the name / number of the error, combined with what you have sad, that is beneficial.  It's the specifics that matter here.

The error code is like the machine that mechanics will plug in to check the computer on your car.  It's a diagnosis of sorts, letting them now what went wrong, and where, so they can go about resolving the issue.

The data most needed is in that button to the far left of the error window you showed us in your first screen capture.  Click it, and post the full data found there.

Apr 7, 2009 at 6:17 PM
Thanks, we'll look into this. In the mean time, check out that video. I think that error may be caused by not marking anything as available (but I'm not sure, just going off memory at the moment, sorry if I'm wrong).
Apr 7, 2009 at 8:41 PM
May be that the problem is I'm running Rawr with a 75 character? Just tried with a 80 character and worked fine...
Apr 7, 2009 at 8:52 PM
Well, that may be related. Rawr won't give accurate results with lower level characters; it's designed for 80 only. But it still shouldn't actually crash. Can you please attach the character file that we can reproduce this with to a new issue in the Issue Tracker, along with the full error text? Thanks.
Apr 7, 2009 at 11:00 PM