This project is read-only.

Mac Users

Topics: Off-Topic
Jun 6, 2009 at 9:47 PM

Does Rawr work with Macs ? Just need a simple answer is all. Thanks


Jun 6, 2009 at 11:12 PM

Simple answer: Yes.

See the readme for details.

Jun 7, 2009 at 3:28 PM

Almost as simple: yes, but not natively.

Jun 7, 2009 at 9:48 PM
Edited Jun 7, 2009 at 11:20 PM

I've got a mac running windows XP on parallels

i tried running this program on it but it says the application failed to initialize properly(0xc0000123)


Any ideas?


EDIT: ah i read the readme and found the answer :P

Jul 3, 2009 at 1:50 PM
Edited Jul 3, 2009 at 1:53 PM

i have rawr running under mono 2.2 and osx 10.5.7. what i would like to do is compile it into a .app. im close, just not there yet. here is what i am using to compile:


macpack -m:1 -o:. -r:/Library/Frameworks/Mono.framework/Versions/Current/lib/ libCocoaSharpGlue.dylib -r:Rawr.base.dll -r:Rawr.Base.XmlSerializers.dll -r:Rawr.exe.config -n:Rawr -a:Rawr.exe

it compiles fine, but when i run rawr form the finder i get a srs errs
 anyone know what im doing wrong?

EDIT: i got it. forgot to compile the data directory :P just add "-r:Data" in there with the other -r's

Jul 3, 2009 at 3:05 PM

Alternatively wait a week or so for Rawr3 which will run natively on a Mac as well as a PC.

Jul 18, 2009 at 12:57 AM

Any update on the native version of Rawr3, so we can run it on Macs? 


Was wondering where to download it from, and if there were additional holdups (its been more than a "week or so" :))


Jul 18, 2009 at 1:57 AM

Yeah, dunno where Levva got the 'week or so' estimate from. It's still in development.

Jul 25, 2009 at 10:26 PM

Any idea on when Rawr3 will come out? I'm trying to get Mono to work for me, but it's being a pain in the arse. >_< It installs but I can't figure out where the heck it is and it wont show up when I search the computer for it.

Jul 26, 2009 at 1:04 AM

When it's ready™

Jul 28, 2009 at 5:49 AM

mono is not an application per se. it doesnt behave the way most mac friendly programs do. the way to access mono after install is to use the terminal app. its kinda tricky to get the hang of because it is a command line interface (think of dos), but if you launch terminal the mono framework is built right in (assuming you installed it :P). now if you would like to get rawr running like a mac friendly application, ie an icon you can click on, run the script i posted above in terminal. first you must navigate to the rawr directory using the cd command. for instance you type "cd users" "cd desktop" "cd rawr". thats where mine is, yours might be somewhere else, you can always type "ls" if you get lost. (that is LS, not to be confused with IS). and dont forget to add the -r:Data like i did. it will take a few minutes to compile depending on the speed of you machine. beware though, running rawr under mono is SLOOOOOOWWWWWWW and somewhat buggy. the buggieness isnt too bad though. hope that helped.

Aug 21, 2009 at 12:01 AM

I've located Rawr using Terminal, and 'cd Rawr' yet when I try to input mono Rawr.exe or the command string listed above, even with '-r.Data' I get a message saying the app already exists with the command string, and with 'mono Rawr.exe' I am told there is no such directory, even though LS brings up ''. Is there something I am doing wrong, or it the best bet to just wait for 3.0?


Aug 22, 2009 at 5:00 PM

Sounds like you don't have Mono installed.

Aug 24, 2009 at 6:24 AM

if you see something that says "" it means it has already been compiled, at least thats what i would assume. what happens when you run the

Sep 1, 2009 at 10:18 AM

I am having trouble locating / launching Rawr. The Rawr v2.2.14 folder is on my desktop but when I enter cd rawr from the desktop dir i get and unknown file error message. If I move the rawr.exe file to the desktop and then hit 'mono rawr.exe' I get this message:

* (rawr.exe:2887): WARNING **: The following assembly referenced from /Users/caseybates/Desktop/rawr.exe could not be loaded:
     Assembly:   Rawr.Base    (assemblyref_index=4)
     Public Key: (none)
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/Users/caseybates/Desktop/).

** (rawr.exe:2887): WARNING **: Could not load file or assembly 'Rawr.Base, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

Unhandled Exception: System.TypeLoadException: A type load exception has occurred.

I am not sure what this means or how I go about having terminal recognize the rawr folder as a directory, I can access certain files with the cd command but not other folders on my desktop. The error message is similar to:

casey-batess-macbook-pro:desktop caseybates$ cd rawr
-bash: cd: rawr: No such file or directory


Sep 1, 2009 at 4:51 PM

The folder is probably named 'Rawr v2.2.14', not 'Rawr', so 'cd rawr' won't work. Rename the folder, or adjust your command. Rawr.exe has to be left in its folder, so it can find all its data.

Sep 1, 2009 at 7:32 PM

Thank you for the help. Renaming the file worked perfectly I'm not sure why it didn't work when I entered Rawr v2.2.14.